Warning Livedoc is no longer being updated and will be deprecated shortly. Please refer to https://documentation.tjhsst.edu.

OpenBSD Sparc Install

From Livedoc - The Documentation Repository
Jump to: navigation, search

OpenBSD Install Guide (SPARC)

Summary

This article will cover the basic process used to install OpenBSD onto a CSL SPARC Server system.

Preparation

Backups, Backups, Backups

Make sure that you have a current backup of all data that is stored on the server. In particular, make sure you have a copy of the SSH keys (/etc/ssh/ssh_host_*) as losing these is BAD™. The only reason for skipping this step is when you are setting up a brand new server.

Necessary Information

You will also need access to the following information at some point during the install (the values below are what the rest of this guide will be using as example values, be sure to substitute your own in):

 * Hostname: nebula
 * Domain: csl.tjhsst.edu
 * FQDN: nebula.csl.tjhsst.edu
 * Server MAC Address: 00:03:BA:88:AF:66
 * Server VLAN: 1600
 * IPv4 Address/Netmask: 198.38.17.80/23
 * IPv4 Gateway: 198.38.17.254
 * IPv6 Address Assignment: Stateless Address Autoconfiguration
 * IPv6 Gateway Assignment: Stateless Address Autoconfiguration
 * DNS Server IPs: 198.38.16.40, 198.38.16.41, and 151.188.14.2

Network Hardware Configuration

If the server is currently setup to use 802.3ad bonding or 802.1Q VLAN tagging; you will need to disable this temporarily.

First we need to find out which switchports the server is connected to. On core0 run:

TJHSST-4500MSL#sh run | inc Nebula
 description Port14 Nebula-0,1
 description Gi4/35 Nebula-0
 description Gi4/43 Nebula-1
 description Fa5/48 Nebula-lom

Then we look at their configuration.

TJHSST-4500MSL#sh run inter Gi4/35
Building configuration...

Current configuration : 305 bytes
!
interface GigabitEthernet4/35
 description Gi4/35 Nebula-0
 switchport access vlan 1600
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 16,1600
 switchport mode trunk ! <--This line indicates that vlan tagging is enabled
 logging event link-status
 channel-protocol lacp
 channel-group 14 mode active ! <--This line indicates that bonding is enabled
 spanning-tree portfast trunk
end

Disable bonding and vlan tagging on at least one interface

TJHSST-4500MSL#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TJHSST-4500MSL(config)#inter Gi4/35
TJHSST-4500MSL(config-if)#no channel-group 14 mode active
TJHSST-4500MSL(config-if)#switchport mode access
TJHSST-4500MSL(config-if)#switchport access vlan 1600
TJHSST-4500MSL(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION
%Portfast has been configured on GigabitEthernet4/35 but will only
 have effect when the interface is in a non-trunking mode.
TJHSST-4500MSL(config-if)#exit
TJHSST-4500MSL(config)#exit
TJHSST-4500MSL#wr mem

The switchport configuration should now look something like this:

TJHSST-4500MSL#sh run inter Gi4/35
Building configuration...

Current configuration : 271 bytes
!
interface GigabitEthernet4/35
 description Gi4/35 Nebula-0
 switchport access vlan 1600
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 16,1600
 switchport mode access
 logging event link-status
 channel-protocol lacp
 spanning-tree portfast
end

Booting the Server

Boot the server to the OpenBSD Install media. In most cases, you will be doing this via netboot. It is also possible to boot from CD or Floppy Disk.

Netboot from Steeltoe

At the OBP Prompt, run:

boot net bsd.rd

You should then see output similar to the following as the system begins to boot:

{3} ok boot net bsd.rd
Boot device: /pci@1c,600000/network@2  File and args: bsd.rd
/pci@1c,600000/network@2: 1000 Mbps full duplex link up
Timeout waiting for ARP/RARP packet
Timeout waiting for ARP/RARP packet
4000 >> OpenBSD BOOT 1.4
/pci@1c,600000/network@2: 1000 Mbps full duplex link up
Using BOOTPARAMS protocol: ip address: 198.38.17.80, hostname: nebula.csl.tjhsst.edu
root addr=198.38.16.144 path=/srv/bsdroot
Booting /pci@1c,600000/network@2/bsd.rd

Note that this assumes the server has already been configured to Netboot; if this is not the case, see the Netboot guide for instructions on configuring OpenBSD Netbooting.

System Information

At the install program prompt, press **I** to start the install process. The Terminal type should be set to **sun**. Then enter the system's hostname.

Welcome to the OpenBSD/sparc64 5.2 installation program.
(I)nstall, (U)pgrade or (S)hell? I      
At any prompt except password prompts you can escape to a shell by
typing '!'. Default answers are shown in []'s and are selected by
pressing RETURN.  You can exit this program at any time by pressing
Control-C, but this can leave your system in an inconsistent state.

Terminal type? [sun] 
System hostname? (short form, e.g. 'foo') nebula

Network Configuration

Select the primary network interface to configure (note that interfaces are named in the BSD style of <drivername><devicenumber>). Enter the IPv4 address and netmask, then enter an IPv6 address or choose rtsol for stateless configuration. Finally, enter done and then enter the default IPv4 gateway, the DNS Domain Name, and the DNS Servers.

Available network interfaces are: cas0 cas1 vlan0.
Which one do you wish to configure? (or 'done') [cas0] 
IPv4 address for cas0? (or 'dhcp' or 'none') [dhcp] 198.38.17.80
Netmask? [255.255.255.0] 255.255.254.0
IPv6 address for cas0? (or 'rtsol' or 'none') [none] rtsol
Available network interfaces are: cas0 cas1 vlan0.
Which one do you wish to configure? (or 'done') [done] 
Default IPv4 route? (IPv4 address, 'dhcp' or 'none') 198.38.17.254
add net default: gateway 198.38.17.254
DNS domain name? (e.g. 'bar.com') [my.domain] csl.tjhsst.edu
DNS nameservers? (IP address list or 'none') [none] 198.38.16.40 198.38.16.41 151.188.14.2

Additional System Information

Specify a root password for the system twice. Choose to start sshd by default, not to start ntpd by default, and not to expect to run the X Window System.

Setup a user account to use instead of the root account using your username and preferred password. Then disable sshd logins to root.

Finally, specify US/Eastern as your timezone.

Password for root account? (will not echo) 
Password for root account? (again) 
Start sshd(8) by default? [yes]
Start ntpd(8) by default? [no]
Do you expect to run the X Window System? [yes] no
Setup a user? (enter a lower-case loginname, or 'no') [no] ahamilto
Full user name for ahamilto? [ahamilto] Andrew Hamilton
Password for ahamilto account? (will not echo) 
Password for ahamilto account? (again) 
Since you set up a user, disable sshd(8) logins to root? [yes] 
What timezone are you in? ('?' for list) [US/Eastern] 

Disk Partitioning

Available disks are: sd0 sd1.
Which disk is the root disk? ('?' for details) [sd0]
Use DUIDs rather than device names in fstab? [yes]
The auto-allocated layout for sd0 is:
#                size           offset  fstype [fsize bsize  cpg]
  a:             1.0G                0  4.2BSD   2048 16384    1 # /
  b:             6.6G          2116608    swap
  c:           136.7G                0  unused
  d:             4.0G         15894912  4.2BSD   2048 16384    1 # /tmp
  e:            16.9G         24300288  4.2BSD   2048 16384    1 # /var
  f:             2.0G         59834880  4.2BSD   2048 16384    1 # /usr
  g:             1.0G         64047744  4.2BSD   2048 16384    1 # /usr/X11R6
  h:            10.0G         66164352  4.2BSD   2048 16384    1 # /usr/local
  i:             2.0G         87147264  4.2BSD   2048 16384    1 # /usr/src
  j:             2.0G         91360128  4.2BSD   2048 16384    1 # /usr/obj
  k:            91.2G         95572992  4.2BSD   2048 16384    1 # /home
Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a]

Set Installation

Let's install the sets!
Location of sets? (cd disk ftp http or 'done') [http]
HTTP/FTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none]
Server? (hostname, list#, 'done' or '?') [mirror.ece.vt.edu]
Server directory? [pub/OpenBSD/5.2/sparc64]

Select sets by entering a set name, a file name pattern or 'all'. De-select
sets by prepending a '-' to the set name, file name pattern or 'all'. Selected
sets are labelled '[X]'.
    [X] bsd           [X] etc52.tgz     [ ] xbase52.tgz   [ ] xserv52.tgz
    [X] bsd.rd        [X] comp52.tgz    [ ] xetc52.tgz
    [X] bsd.mp        [X] man52.tgz     [ ] xshare52.tgz
    [X] base52.tgz    [X] game52.tgz    [ ] xfont52.tgz
Set name(s)? (or 'abort' or 'done') [done] +x*
    [X] bsd           [X] etc52.tgz     [X] xbase52.tgz   [X] xserv52.tgz
    [X] bsd.rd        [X] comp52.tgz    [X] xetc52.tgz
    [X] bsd.mp        [X] man52.tgz     [X] xshare52.tgz
    [X] base52.tgz    [X] game52.tgz    [X] xfont52.tgz
Set name(s)? (or 'abort' or 'done') [done] -game*
    [X] bsd           [X] etc52.tgz     [X] xbase52.tgz   [X] xserv52.tgz
    [X] bsd.rd        [X] comp52.tgz    [X] xetc52.tgz
    [X] bsd.mp        [X] man52.tgz     [X] xshare52.tgz
    [X] base52.tgz    [ ] game52.tgz    [X] xfont52.tgz
Set name(s)? (or 'abort' or 'done') [done] -xserv52.tgz
    [X] bsd           [X] etc52.tgz     [X] xbase52.tgz   [ ] xserv52.tgz
    [X] bsd.rd        [X] comp52.tgz    [X] xetc52.tgz
    [X] bsd.mp        [X] man52.tgz     [X] xshare52.tgz
    [X] base52.tgz    [ ] game52.tgz    [X] xfont52.tgz
Set name(s)? (or 'abort' or 'done') [done] -xetc52*
    [X] bsd           [X] etc52.tgz     [X] xbase52.tgz   [ ] xserv52.tgz
    [X] bsd.rd        [X] comp52.tgz    [ ] xetc52.tgz
    [X] bsd.mp        [X] man52.tgz     [X] xshare52.tgz
    [X] base52.tgz    [ ] game52.tgz    [X] xfont52.tgz
Set name(s)? (or 'abort' or 'done') [done]

Reboot

CONGRATULATIONS! Your OpenBSD install has been successfully completed!
To boot the new system, enter 'reboot' at the command prompt.
When you login to your new system the first time, please read your mail
using the 'mail' command.

# reboot

Postinstall

KSH Prompt

Email Configuration

SSH Keys/Keytab

Networking

Ports tree

/etc/rc.conf

Backups

Additional Software